한글 입력기

한글 입력기

Microsoft 한글 입력기 2002

Microsoft 한글 입력기 2000

입력 글자

지원 자판

입력 도구 모음 사용자 지정

소프트 키보드

텍스트 서비스 및 입력 언어 대화 상자

다국어 입력기 지원

도구 모음 최소화


한글 입력기(한글 IME)

한글 입력기(한글 IME)는 모든 응용 프로그램에서 한글 및 한자를 입력할 수 있게 해주는 프로그램입니다. Microsoft 한글 입력기는 새로운 구조의 입력 시스템으로 다국어 입력기 및 필기 인식 등 다양한 입력기를 통합하여 사용할 수 있습니다. 한글 입력기는 Microsoft 한글 입력기 2000과 Microsoft 한글 입력기 2002 모드로 작동합니다. Microsoft 한글 입력기 2002는 Microsoft Office XP와 같이 새로운 입력 시스템을 지원하는 프로그램에서만 작동하며, 기존 응용 프로그램을 사용할 경우에는 자동으로 Microsoft 한글 입력기 2000으로 작동합니다.


Microsoft 한글 입력기 2002

Microsoft 한글 입력기 2002는 다음의 입력 도구 모음을 통하여 사용할 수 있습니다.

각 아이콘의 기능은 다음과 같습니다.

   아이콘은 현재 선택된 입력기가 Microsoft 한글 입력기 2002임을 나타냅니다. 사용자 시스템에 하나 이상의 한글 입력기가 설치된 경우(예: Microsoft Word 2002의 옛한글 입력기), 이 아이콘을 클릭하여 다른 입력기를 선택할 수 있습니다. 사용자 시스템에 하나의 한글 입력기만 설치된 경우라면 이 아이콘은 작동하지 않습니다.

      아이콘은 각각 현재의 입력 모드가 한글인지 또는 영어인지 알려줍니다. 이 아이콘을 클릭하거나 자판의 한/영 키를 누르면 한글/영어 입력 모드를 바꿀 수 있습니다.

   아이콘은 입력된 한글을 한자로 변환할 때 사용합니다. 아래 그림과 같이 한글 '국'을 입력한 경우 이 한자 아이콘을 누르거나 자판의 한자 키 또는 오른쪽 Ctrl을 누르면 '국' 음을 가진 한자 목록이 입력 글자 아래쪽에 나타납니다. 사용자가 원하는 한자를 마우스로 선택하거나 해당 한자의 숫자를 눌러 선택할 수 있습니다.


Microsoft 한글 입력기 2000

Microsoft 한글 입력기 2000은 다음의 입력 도구 모음을 통하여 사용할 수 있습니다.

각 아이콘의 기능은 다음과 같습니다.

      아이콘은 각각 현재의 입력 모드가 한글인지 영어인지 알려 줍니다. 이 아이콘을 클릭하거나 자판의 한/영 키를 누르면 한글/영어 입력 모드를 바꿀 수 있습니다.

   아이콘은 입력된 한글을 한자로 변환할 때 사용합니다. 한글 '국'을 입력한 경우 이 한자 아이콘을 클릭하거나 자판의 한자 키 또는 오른쪽 Ctrl을 누르면 '국' 음을 가지고 있는 한자 목록이 화면 오른쪽 아래에 나타납니다. 사용자가 원하는 한자를 마우스로 선택하거나 해당 한자의 숫자를 눌러 선택할 수 있습니다. 한자 위로 마우스를 가져가면 잠시 후 음과 훈이 표시되며 이 기능을 이용하면 원하는 한자를 보다 쉽게 찾을 수 있습니다.

   아이콘을 클릭하면 아래 그림과 같은 확장 입력기가 실행되며 이를 통해 필기 인식 기능을 사용할 수 있습니다. 확장 입력기를 사용하는 방법은 확장 입력기 도움말을 참고하십시오.


입력 글자

Microsoft 한글 입력기 2002는 KS X 1005-1(KS C 5700-1995)의 11,172자의 완성형 한글과 51개의 한글 자소 입력을 지원합니다. 한자의 경우 KS X 1005-1(KS C 5700-1995)에 정의된 K0 한자(4,888자)와 K1 한자(2,856자)를 지원하며, KS X 1001-1998(KS C 5601-1998)에서 추가된 유로화 및 등록 기호 입력도 지원합니다.


지원 자판

다음과 같은 세 가지 자판을 지원합니다. 입력 도구 모음의 옵션 단추를 클릭하여 설정을 선택한 후 텍스트 서비스 및 입력 언어 대화 상자에서 속성 단추를 클릭하여 변경할 수 있습니다.

  • 두벌식

    • 현재 표준으로 채택되어 있는 자판으로 영문 키에 맞게 한글의 자모가 배열되어 있습니다.

  • 세벌식 390 자판

    • 세벌식 자판은 두벌식과 달리 한글 초성, 중성, 종성을 분리하여 키가 배치되어 있고 자판 배열에 따라 세벌식 390 자판과 세벌식 최종 자판 두 가지 종류가 있습니다. 세벌식 390 자판은 세벌식 최종 자판을 배우기 쉽도록 수정한 것입니다.

  • 세벌식 최종 자판

    • 공병우 박사가 제안한 자판으로 공병우 자판이라고도 합니다.


입력 도구 모음 사용자 지정

입력 도구 모음에 사용자가 자주 사용하는 아이콘만을 표시할 수 있습니다. 아래와 같이 옵션 단추를 클릭하면 기본 도구 모음에 표시되지 않는 전자/반자 전환 기능과 소프트 키보드를 선택하여 표시할 수 있습니다.

소프트 키보드는 Microsoft 한글 입력기 2002에서만 지원됩니다.


소프트 키보드

옵션 메뉴 목록에서 소프트 키보드를 선택하면 도구 모음에 다음과 같이 소프트 키보드 아이콘이 추가되어 나타납니다. 소프트 키보드는 Microsoft 한글 입력기 2002를 사용할 때만 나타납니다.

소프트 키보드 아이콘을 클릭하면 현재의 키보드 상태에 따라 한글 두벌식, 한글 세벌식 390, 한글 세벌식 최종 또는 영문 키보드가 나타납니다. 다음은 한글 두벌식의 경우입니다. 키보드를 계속 사용하여 입력하거나 마우스를 이용하여 입력할 수 있습니다.


텍스트 서비스 및 입력 언어 대화 상자

옵션 메뉴 목록에서 설정을 선택하면 다음과 같은 대화 상자가 나타납니다.

이 대화 상자에서 도구 모음의 설정을 변경하거나 새로운 입력기 또는 다국어 입력기 등을 추가로 설치할 수 있습니다.

  • 입력 언어 추가 대화 상자
    •

추가 단추를 클릭하면 다음의 대화 상자가 표시되어 다른 언어 입력기를 추가로 설치할 수 있습니다.

  • 속성 대화 상자
    •

속성 단추를 클릭하면 다음 대화 상자가 나타납니다.

자판 선택

두벌식 또는 세벌식 자판을 선택합니다.

삭제할 때 자소 단위로

입력 도중 미완성 글자를 삭제할 때 글자 전체를 삭제할 것인지 아니면 자소 단위로 삭제할 것인지 지정합니다.

확장한자(KS C 5657) 입력하기

한자를 변환할 때 확장한자의 사용 여부를 선택합니다. 이 옵션이 선택되어 있으면 확장 한자는 파란색으로 표시되어 나타납니다.


다국어 입력기 지원

사용자 시스템에 다국어 입력기가 추가로 설치된 경우 도구 모음에 표시됩니다. 다음은 Microsoft Japanese IME 2002가 동시에 설치된 경우입니다. 입력 도구 모음에서 사용자가 원하는 언어를 자유로이 선택하여 동시에 사용할 수 있습니다.


도구 모음 최소화

아래와 같이 최소화 단추를 클릭하면 도구 모음을 최소화하여 작업 표시줄에 나타낼 수 있습니다.